[solved] Problème Megadrive Jap VA6 switchée et 50Hz

Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Seifer63 le Ven 19 Juin 2020 - 21:12

Bonjour à tous,
ce sujet fait suite à un autre que j'avais ouvert dans une autre partie du forum ( https://www.gamopat-forum.com/t108301-identification-d-un-mod-sur-une-megadrive-va5-jap ).

Pour résumer, j'ai une Megadrive 1 Jap (model VA5) que j'ai reçu il y a quelques années avec 2 switchs (zone et fréquence) et qui a un problème étrange avec le 50Hz. Lorsque je démarre un jeu en 50Hz, l'image est identique au 60Hz (plein écran et jeux Pal accéléré...).

Voici les résultats de tests que j'ai faits avec les jeux Sonic 3 (Jap) et Street Fighter II' CE (Pal) (j'ai choisi ces 2 jeux car ils sont zonés) :

Avec Sonic 3 Jap :
-Switchs Jap + 60Hz -> Le jeu fonctionne (normal)
-Switchs Eng + 60Hz -> Message d'erreur de zone (normal)
-Switchs Eng + 50Hz -> Message d'erreur de zone (normal)
-Switchs Jap + 50Hz -> Ecran noir (normal - je suppose car jap+50Hz étant improbable)

Avec Street Fighter II' CE Pal :
-Switchs Eng + 50Hz -> Le jeu fonctionne mais plein écran et musique accélérée (PAS NORMAL)
-Switchs Eng + 60Hz -> Message d'erreur de zone (normal)
-Switchs Jap + 60Hz -> Message d'erreur de zone (normal)
-Switchs Jap + 50Hz -> Message d'erreur de zone (normal)

Tout ceci me fait penser qu'il n'y a pas de problème au niveau des 2 switchs mais plutôt au niveau de la carte mère...
De plus, lorsque la console est en 50Hz, il y a des artefacts vidéos en tout haut de l'image (constaté sur Sonic 1 Jap et SFII'CE Pal)

[solved] Problème Megadrive Jap VA6 switchée et 50Hz 00110    [solved] Problème Megadrive Jap VA6 switchée et 50Hz 00210


J'ai également testé avec plusieurs cable scart différents (certain vont chercher la synchro sur le pin 3 du DIN8, d'autres sur le pin 7) et le problème reste le même.
Bref, je tourne en rond et je ne sais plus trop où chercher...


Dernière édition par Seifer63 le Mer 29 Juil 2020 - 19:25, édité 2 fois
Seifer63
Seifer63
Patient en incubation

Masculin Nombre de messages : 39
Age : 38
Localisation : Clermont Ferrand
Date d'inscription : 23/01/2019

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Seifer63 le Jeu 25 Juin 2020 - 0:07

Sinon, quelqu'un a t-il déjà switché une VA5 Jap, que je sache au moins si l'image est supposée être "compressée verticalement" en 50Hz ? La question a l'air débile mais là, je n'ai vraiment plus d'idée où chercher le problème et je suis à deux doigts de chercher une autre Megadrive Jap Sad
Seifer63
Seifer63
Patient en incubation

Masculin Nombre de messages : 39
Age : 38
Localisation : Clermont Ferrand
Date d'inscription : 23/01/2019

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Seifer63 le Lun 20 Juil 2020 - 19:50

Cela n'intéressera surement personne mais j'ai continué à faire des tests :

-J'ai testé ma console avec la rom GenTest V3.0 :
   -En 60Hz / Japon la console est bien détectée comme ayant pour zone "japon"
   -En 50Hz / Japon la console est bien détectée comme ayant pour zone "japon (50Hz)"
Donc mes 2 switchs fonctionnent correctement !

En regardant les fréquences sur mon OSSC, je constate que la fréquence est toujours de 59.91Hz, que la console démarre en 50Hz ou en 60Hz. Donc j'ai bel et bien un problème d'affichage avec le 50Hz et je n'ai aucune idée d'où ça vient...

Au passage, j'ai toujours cru que ma console était une VA5 mais j'ai réalisé qu'elle avait le TMSS... s'agit il d'une VA6 (ou d'une VA5 exotique) ?
Seifer63
Seifer63
Patient en incubation

Masculin Nombre de messages : 39
Age : 38
Localisation : Clermont Ferrand
Date d'inscription : 23/01/2019

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Anthotho le Mer 22 Juil 2020 - 19:35

Je dois récupérer une Megadrive Jap HS demain avec un collègue.
J'essaierai de trouver une réponse a ton problème en même temps que je la répare, pour l'instant je n'ai jamais eu de Jap entre les mains.
Anthotho
Anthotho
Patient en incubation

Masculin Nombre de messages : 85
Age : 32
Localisation : Quimper
Date d'inscription : 07/03/2020

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par ace76 le Mer 22 Juil 2020 - 21:23

Fais gaffe aux jeux pal optimisés en 50hz,si la console est en 60hz ça nuit au framerate.Essaye plutot avec des Sonic 1 ou Sor 1 qui switche les polices de  caractéres automatiquement.t'as des photos du serial de ta console et du type?
ace76
ace76
Infirmier

Masculin Nombre de messages : 4023
Age : 44
Localisation : lyon
Date d'inscription : 21/04/2013

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Seifer63 le Jeu 23 Juil 2020 - 11:10

Merci pour vos réponses à tous les deux :)
Je referai un test ce soir avec Sonic 1 (je l'ai en jap mais il me semble que le programme dans la cartouche est commun au 3 zones) en 50Hz et je verrai bien quelle fréquence est donnée par l'OSSC.
D'après un test avec Sonic 1 que j'avais fait il y a quelques semaines, en 50Hz l'image était en plein écran avec des artefacts vidéos en haut de l'image (voir 2nd image du 1er post)
Seifer63
Seifer63
Patient en incubation

Masculin Nombre de messages : 39
Age : 38
Localisation : Clermont Ferrand
Date d'inscription : 23/01/2019

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Seifer63 le Jeu 23 Juil 2020 - 18:57

Ça y est, j'ai fait le test avec sonic 1 (jap) - A noter que je règle mes switchs avant de démarrer

-Jap/60Hz : plein écran, vitesse normal (pour du NTSC), musique à la bonne vitesse, pas d'artefacts vidéos, l'OSSC affiche 59.91Hz.
-En/50Hz : pleine écran, le jeux saccade (il n'est pas fluide), la musique est à la vitesse du NTSC (donc trop rapide), il y a des artefacts videos et l'OSSC affiche toujours 59.91Hz.

A noter que, quelque soit la config, rien ne change lorsque je switch "à chaud", une fois le jeux lancé.

Comment est géré le passage du 50 au 60Hz dans cette console ? S'agit-il d'un changement d'alimentation de l'oscillateur ?
Seifer63
Seifer63
Patient en incubation

Masculin Nombre de messages : 39
Age : 38
Localisation : Clermont Ferrand
Date d'inscription : 23/01/2019

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Seifer63 le Ven 24 Juil 2020 - 3:29

@ace76 a écrit:t'as des photos du serial de ta console et du type?
Ma console est en fait une VA6 jap (je pensais à tort qu'il s'agissait d'une VA5), Model n° HAA-2510

Ce modèle comporte les puces 315-5313A (VDP) et 315-5433 (TMSS)

En regardant les différents chips de la console, j'ai remarquée que la fréquence (pal/ntsc donc JP3/4 sur la carte mère) partait sur le pin 154 du 315-5433, pin 46 du 315-3513A (VDP) et pin 7 du CXA1145 (encodeur graphique).
Après un test, j'ai vu qu'il y avait pas de continuité entre le pin 46 du VDP et le couple JP3/4. J'ai donc levé ce pin et testé la piste apparaissant en dessous et là il y avait bien continuité avec JP3/4 cheers

Sûre d'avoir trouvé le problème (en plus, ça correspondant bien mes symptômes), j'ai donc laissé ce pin levé et je l'ai relié directement à la sortie du couple JP3/4 et...........écran noir [solved] Problème Megadrive Jap VA6 switchée et 50Hz 422508 
J'ai vérifié les soudures, les continuité sur les pins autour du 46, vérifié qu'il s'agissait bien du pin 46, bref, à priori pas de problème. Du coup je décide de remettre la console comme avant et....toujours écran noir [solved] Problème Megadrive Jap VA6 switchée et 50Hz 422508 

Du coup je laisse tomber pour ce soir car la seule envie que j'ai est de mettre un grand coup de masse sur la console et balancer les bouts à la poubelle !
Seifer63
Seifer63
Patient en incubation

Masculin Nombre de messages : 39
Age : 38
Localisation : Clermont Ferrand
Date d'inscription : 23/01/2019

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Seifer63 le Ven 24 Juil 2020 - 15:07

Bon ben j'ai re-vérifier les continuité sur les pin 40 à 55 (toutes celles autours du 46 que j'aurais éventuellement pu endommager sans mon rendre compte) et il n'y a aucun problème. J'ai entièrement recablé mes 2 switchs, testé les continuités selon les positions des switchs, là encore aucuns problème. La console s'allume mais j'ai un écran noir et pas de son.


Dernière édition par Seifer63 le Dim 26 Juil 2020 - 22:24, édité 1 fois
Seifer63
Seifer63
Patient en incubation

Masculin Nombre de messages : 39
Age : 38
Localisation : Clermont Ferrand
Date d'inscription : 23/01/2019

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Seifer63 le Dim 26 Juil 2020 - 22:24

Par acquis de conscience, j'ai fait un dernier test avec un Master System Converter et les jeux Master System passe nickel (même le switchs 50/60 fonctionne.)
En revanche, je n'ai toujours qu'un écran noir et pas de son quand je lance un jeux Megadrive (j'ai testé 4 jeux différents)

J'ai testé les continuité sur tous les pins de tous les chips sur la carte mère et je n'est trouvé aucunes piste coupée Sad

Quelqu'un à t il une dernière idée ? Sad Sad
Seifer63
Seifer63
Patient en incubation

Masculin Nombre de messages : 39
Age : 38
Localisation : Clermont Ferrand
Date d'inscription : 23/01/2019

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Anthotho le Lun 27 Juil 2020 - 15:38

Tu pourrais envoyer des photos de la carte et des modifications ?
Anthotho
Anthotho
Patient en incubation

Masculin Nombre de messages : 85
Age : 32
Localisation : Quimper
Date d'inscription : 07/03/2020

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Seifer63 le Mar 28 Juil 2020 - 2:37

Voici des photos de la carte mère avec les modifs sur VDP (pin 50 levé et pin 46 reliè au switch 50/60Hz)

Note: J'ai rajouté un connecteur 4 broches au niveau des 2 switchs pour pouvoir enlever la coque plus facilement



[solved] Problème Megadrive Jap VA6 switchée et 50Hz Cm10


[solved] Problème Megadrive Jap VA6 switchée et 50Hz Chip110


[solved] Problème Megadrive Jap VA6 switchée et 50Hz Chip210
Seifer63
Seifer63
Patient en incubation

Masculin Nombre de messages : 39
Age : 38
Localisation : Clermont Ferrand
Date d'inscription : 23/01/2019

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Seifer63 le Mar 28 Juil 2020 - 2:43

La seule bonne nouvelle c'est que l'écran noir que j'obtiens en mettant un jeu Megadrive est à 59.91Hz pour 60Hz et à 50.15Hz pour 50Hz, ce qui correspond au fréquence théorique que je devrais avoir. Avant la modif, certes les jeux fonctionnaient mais j'avais toujours 59.91, que le switch de fréquence soit sur 50 ou 60Hz...

J'ai néanmoins essayé de remettre le pin 46 tel qu'il était avant mais sans succés, l'image reste noire Sad
Seifer63
Seifer63
Patient en incubation

Masculin Nombre de messages : 39
Age : 38
Localisation : Clermont Ferrand
Date d'inscription : 23/01/2019

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Anthotho le Mar 28 Juil 2020 - 10:22

Ducou j'ai regardé la mienne et j'ai la même carte mère que toi:
[solved] Problème Megadrive Jap VA6 switchée et 50Hz Img_2032

Pour l'instant j'ai un écran noir car l'ancien propriétaire a fait le bourrin au niveau du port cartouche, il a fêlé le pcb et coupé des pistes.
Dès qu'elle refonctionne, je la Switch pour voir ce que j'obtiens.

Les pistes a l'arrière des jumper sont bien coupé ?

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Img_2033
Anthotho
Anthotho
Patient en incubation

Masculin Nombre de messages : 85
Age : 32
Localisation : Quimper
Date d'inscription : 07/03/2020

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Seifer63 le Mar 28 Juil 2020 - 12:03

Ouais, les 2 petites pistes à l'arrière des jumpers sont bien coupées.
Vu que tu as la même version que la mienne, tu pourrais me confirmer que tu as bien une continuité entre le pin 46 du VDP et la partie commune à JP3 et JP4 ?

C'est toi qui a rajouté les fils qui partent du pin 60 du CPU vers les deux condensateurs ?

(Faut vraiment faire le bourrin pour fêler le pcb ! :O )
Seifer63
Seifer63
Patient en incubation

Masculin Nombre de messages : 39
Age : 38
Localisation : Clermont Ferrand
Date d'inscription : 23/01/2019

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Anthotho le Mar 28 Juil 2020 - 12:51

Si tu parle du petit fil noir, oui c'est moi mais il n'est pas relié au condensateurs, il est juste un peu long.
Je l'ai mis car une piste est coupée au niveau de la vis du port cartouche (pcb fêlé).

Je regarderai ça en fin de journée pour le pin 46 et je te ferai un retour.

Oui il a fait le bourrin, ja l'impression qu'il à changé (ou modifié) le port cartouche , il n'y a plus de plastique là ou il est fixé par les vis
Anthotho
Anthotho
Patient en incubation

Masculin Nombre de messages : 85
Age : 32
Localisation : Quimper
Date d'inscription : 07/03/2020

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par ace76 le Mar 28 Juil 2020 - 15:18

C'est etrange,pour les changement de fréquences et de région tu n'as pas a  intervenir sur le VDP normalement.
ace76
ace76
Infirmier

Masculin Nombre de messages : 4023
Age : 44
Localisation : lyon
Date d'inscription : 21/04/2013

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Seifer63 le Mar 28 Juil 2020 - 16:49

D'après les schémas que j'ai récupéré, sur les V5 et V6, la fréquence part directement des jumpers 3 et 4 vers le pin 154 du 315-5402 (IC4), le pin 46 du 315-5313A (VPD, IC8) et le pin 7 du CXA-1145 (Video Encoder, IC13).


Après, je peux me tromper, ça reste assez obscure pour moi...
Seifer63
Seifer63
Patient en incubation

Masculin Nombre de messages : 39
Age : 38
Localisation : Clermont Ferrand
Date d'inscription : 23/01/2019

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Anthotho le Mar 28 Juil 2020 - 18:59

J'ai bien continuité entre jp3/4 et le pin 46
Anthotho
Anthotho
Patient en incubation

Masculin Nombre de messages : 85
Age : 32
Localisation : Quimper
Date d'inscription : 07/03/2020

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Seifer63 le Mar 28 Juil 2020 - 23:18

C’est presque une mauvaise nouvelle, ça signifie que mon problème vient d’ailleurs :/
En tout cas, merci d’avoir checker Wink
Seifer63
Seifer63
Patient en incubation

Masculin Nombre de messages : 39
Age : 38
Localisation : Clermont Ferrand
Date d'inscription : 23/01/2019

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Seifer63 le Mer 29 Juil 2020 - 19:34

C’est réparé :)
Il s’agissait d’une mauvaise soudure sur la résistance et le pin 6 du 68000 (IC1). Effectivement, le 68000 et ses 2 chips de RAM ne sont pas utilisé en mode Master System.

Moralité, en cas d’anomalie sur les fréquences pal/ntsc, penser à vérifier les liaisons entre les jumpers 3-4 et le pin 46 du VDP, le pin 7 de l’encoder video et enfin le pin 154 du 315-5402 (IC4 sur VA5 et 6).
Si vous ne pouvez lire les jeux Master System sans problème mais que vous avez un écran noir sans son avec les jeux Megadrive, vérifiez le 68000 et la RAM (IC1, 2 et 3)
Seifer63
Seifer63
Patient en incubation

Masculin Nombre de messages : 39
Age : 38
Localisation : Clermont Ferrand
Date d'inscription : 23/01/2019

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par ace76 le Mer 29 Juil 2020 - 21:11

Bravo,mais je comprends pas,jamais vu une soudure lacher sur une Megadrive,sauf sur la prise Din 8 broches.
ace76
ace76
Infirmier

Masculin Nombre de messages : 4023
Age : 44
Localisation : lyon
Date d'inscription : 21/04/2013

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Seifer63 le Mer 29 Juil 2020 - 21:30

La soudure en question avait l’air bien terne et il est possible qu’elle ait laché à cause des fils du switch qui passaient sous la carte mère (avant que je les refasse) et qui ont pu appuyer dessus une fois la console fermée... en tout cas, c’est la seule explication que j’ai Very Happy
Seifer63
Seifer63
Patient en incubation

Masculin Nombre de messages : 39
Age : 38
Localisation : Clermont Ferrand
Date d'inscription : 23/01/2019

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par lincruste le Mer 29 Juil 2020 - 22:05

Purée bien joué. Merci d'avoir régulièrement posté tes progrès, je ne contribuais pas parce que je ne pouvais pas aider mais je suivais de près chaque mise à jour.
lincruste
lincruste
Infirmier

Masculin Nombre de messages : 3295
Age : 41
Localisation : RP
Date d'inscription : 07/06/2014

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Anthotho le Mer 29 Juil 2020 - 23:10

Je vais checker sur la mienne également car elle ne boot pas les jeux, j'ai pas l'adaptateur pour essayer les jeux master system mais dans le doute...
Anthotho
Anthotho
Patient en incubation

Masculin Nombre de messages : 85
Age : 32
Localisation : Quimper
Date d'inscription : 07/03/2020

Revenir en haut Aller en bas

[solved] Problème Megadrive Jap VA6 switchée et 50Hz Empty Re: [solved] Problème Megadrive Jap VA6 switchée et 50Hz

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum