Probleme neo geo

Aller en bas

Probleme neo geo

Message par eddyfoucault le Dim 4 Mar 2018 - 10:43

Bonjour à tous,

Je déterre aujourd'hui un probleme vieux de plus de 20 ans.
Lors d'une session de jeu avec un pote,tout à coup ma console préférée s'est mise à déconner sur la moitié de l'écran.
A l'époque, il n'y avait pas internet pour se renseigner. Je l'ai emmener chez divers "spécialistes" qui se sont contenter de la brancher et voir qu'elle en fonctionnait pas. Moi même, début des années 2000, et espérant que ce long sommeil provoque un miracle, j'ai fait de même, en pire (ayant entre temps racheté une console, et changé de télé, j'ai refait le test avec le mauvais adaptateur secteur, avec une peritel non modifiée
 qui n'abaissait pas le 5V au bon niveau pour la commutation rapide ...)
Et voilà, enfin, je me suis mis dans de bonnes conditions (adaptateur 5V officiel en cohérence avec le numéro de série de la console, câble peritel modifié, qui fonctionne à merveille sur ma seconde console), et j'ai pris quelques photos, des fois que l'un de vous ai eu le même problème (et en ai trouvé la source ... même si d'après moi c'est foutu)

Seule la moitié de l'écran est impacté, et pas sur tous les plans (du coup, certaines phases de jeu ne laissent pas entrevoir de probleme)




eddyfoucault
Patient contaminé

Masculin Nombre de messages : 310
Age : 42
Localisation : lyon
Date d'inscription : 20/11/2014

http://eddystoys.blogspot.fr/

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par Le super cancre le Dim 4 Mar 2018 - 11:05

Inscrit toi sur neogeo système y'a des membres super calé sur l' aes en réparation et conseils un super forum avec une super ambiance et des membres super sympathique
avatar
Le super cancre
Patient contaminé

Masculin Nombre de messages : 550
Age : 34
Localisation : france
Date d'inscription : 22/07/2016

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par eddyfoucault le Dim 4 Mar 2018 - 11:19

merci beaucoup pour ce conseil, je ne connaissais pas

eddyfoucault
Patient contaminé

Masculin Nombre de messages : 310
Age : 42
Localisation : lyon
Date d'inscription : 20/11/2014

http://eddystoys.blogspot.fr/

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par tilou le Dim 4 Mar 2018 - 11:29

c'est vrai que ce genre de glitch graphique fait avant tout penser a un problème de tension
toute tes cartouches aes localise le problème au même endroit ?
avatar
tilou
Guéri miraculeux

Masculin Nombre de messages : 2748
Age : 41
Localisation : salon de pce
Date d'inscription : 10/07/2012

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par trunk70 le Dim 4 Mar 2018 - 11:47

Si c'est comme sur MVS (et ça doit l'être à mon avis), c'est juste la mémoire vidéo qui est à remplacer. J'ai connu le même genre de souci (à cause de tests que je faisais pour consoliser un MVS et une mauvaise tension envoyée au slot...) et en faisant quelques recherches j'avais trouvé ça. Je les ai remplacées (c'est trouvable pour pas cher sur ebay) et tout était rentré dans l'ordre.

Une piste à vérifier peut être en espérant que ça se remplace aussi facilement que sur un slot et que ça ne soit pas miniaturisé par exemple (Il faut dessouder et ressouder).

J'avais fait une vidéo YouTube à l'époque pour illustrer cela, je vais essayer de la retrouver.


Edit :





Dernière édition par trunk70 le Dim 4 Mar 2018 - 11:49, édité 1 fois
avatar
trunk70
Patient contaminé

Masculin Nombre de messages : 397
Age : 40
Localisation : Belgique (Mons)
Date d'inscription : 24/07/2012

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par eddyfoucault le Dim 4 Mar 2018 - 11:47

Oui oui, toutes ... et surtout, j'insiste, c'est arrivé en cours de jeu il y a 20 ans (donc pas de gourance de transfo, de TV ou autre) ... heureusement, après un achat décevant de SNES, à l'époque j'avais trouvé une NG pas chere à la FNAC. Mais bon, si y'avait moyen d'en retrouver une seconde ...

eddyfoucault
Patient contaminé

Masculin Nombre de messages : 310
Age : 42
Localisation : lyon
Date d'inscription : 20/11/2014

http://eddystoys.blogspot.fr/

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par eddyfoucault le Dim 4 Mar 2018 - 11:49

@trunk70 a écrit:Si c'est comme sur MVS (et ça doit l'être à mon avis), c'est juste la mémoire vidéo qui est à remplacer. J'ai connu le même genre de souci (à cause de tests que je faisais pour consoliser un MVS et une mauvaise tension envoyée au slot...) et en faisant quelques recherches j'avais trouvé ça. Je les ai remplacées (c'est trouvable pour pas cher sur ebay) et tout était rentré dans l'ordre.

Une piste à vérifier peut être en espérant que ça se remplace aussi facilement que sur un slot et que ça ne soit pas miniaturisé par exemple (Il faut dessouder et ressouder).

J'avais fait une vidéo YouTube à l'époque pour illustrer cela, je vais essayer de la retrouver.

Ah merci, c'est sympa ça !! j'attends ton lien avec impatience

eddyfoucault
Patient contaminé

Masculin Nombre de messages : 310
Age : 42
Localisation : lyon
Date d'inscription : 20/11/2014

http://eddystoys.blogspot.fr/

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par trunk70 le Dim 4 Mar 2018 - 11:50

@eddyfoucault a écrit:
@trunk70 a écrit:Si c'est comme sur MVS (et ça doit l'être à mon avis), c'est juste la mémoire vidéo qui est à remplacer. J'ai connu le même genre de souci (à cause de tests que je faisais pour consoliser un MVS et une mauvaise tension envoyée au slot...) et en faisant quelques recherches j'avais trouvé ça. Je les ai remplacées (c'est trouvable pour pas cher sur ebay) et tout était rentré dans l'ordre.

Une piste à vérifier peut être en espérant que ça se remplace aussi facilement que sur un slot et que ça ne soit pas miniaturisé par exemple (Il faut dessouder et ressouder).

J'avais fait une vidéo YouTube à l'époque pour illustrer cela, je vais essayer de la retrouver.

Ah merci, c'est sympa ça !! j'attends ton lien avec impatience

J'ai édité mon post avec les vidéos.
avatar
trunk70
Patient contaminé

Masculin Nombre de messages : 397
Age : 40
Localisation : Belgique (Mons)
Date d'inscription : 24/07/2012

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par ace76 le Lun 5 Mar 2018 - 22:17

Je confirme,problème de ram video.J'avais changé les 2 chipsets toshiba.
avatar
ace76
Infirmier

Masculin Nombre de messages : 3057
Age : 42
Localisation : lyon
Date d'inscription : 21/04/2013

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par Hpman le Mar 6 Mar 2018 - 4:26

Je parierais pas sur un problème VRAM, il y a les bonnes choses au bon endroit.

Elle balance un écran de quelle couleur quand on l'allume sans cartouche ?

Hpman
Patient contaminé

Masculin Nombre de messages : 289
Age : 41
Localisation : Lille
Date d'inscription : 22/08/2014

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par eddyfoucault le Mar 6 Mar 2018 - 8:44

Salut,

je participe aussi à une discussion sur neo geo system, dont un membre sympa m'a orienté vers la coupure de pistes ... mais je n'ai rien vu. Alors la piste des composants toshiba m'intéresse.

@trunk70: s'agit il des composants sur la photo (mal prise) ? Cela se trouve dans le commerce ? avais tu les mêmes symptomes ?
@Hpman: bleu


eddyfoucault
Patient contaminé

Masculin Nombre de messages : 310
Age : 42
Localisation : lyon
Date d'inscription : 20/11/2014

http://eddystoys.blogspot.fr/

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par ichigobankai le Mar 6 Mar 2018 - 9:11

pour les couleurs :
Blue = All tests passed (does not test z80).
Red = WorkRAM error (0x100000 region).
Green = PaletteRAM error (0x400000 region).
Yellow = VideoRAM error (programmed through custom port).
Pink = Bios selfcheck error (0xC00000 region).
Cyan = Memory card error (only tested if card in unit and blank).

il existe un bios de test (mais il faut déjà que ton bios soit sur socket pour pouvoir l'utiliser) :
http://smkdan.eludevisibility.org/neo/diag/
avatar
ichigobankai
Patient incurable

Masculin Nombre de messages : 1396
Age : 39
Localisation : 49
Date d'inscription : 04/04/2011

http://www.mastersystem-france.com

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par eddyfoucault le Mar 6 Mar 2018 - 9:39

@ichigobankai a écrit:pour les couleurs :
Blue = All tests passed (does not test z80).
Red = WorkRAM error (0x100000 region).
Green = PaletteRAM error (0x400000 region).
Yellow = VideoRAM error (programmed through custom port).
Pink = Bios selfcheck error (0xC00000 region).
Cyan = Memory card error (only tested if card in unit and blank).

il existe un bios de test (mais il faut déjà que ton bios soit sur socket pour pouvoir l'utiliser) :
http://smkdan.eludevisibility.org/neo/diag/

All tests passed ... mais je n'ai que la moitié de l'écran :)

Est il possible que mon alimentation en soit la cause ? (je commence à me poser des questions ... je vais tenter une autre alim 5V en fin de semaine ... )

eddyfoucault
Patient contaminé

Masculin Nombre de messages : 310
Age : 42
Localisation : lyon
Date d'inscription : 20/11/2014

http://eddystoys.blogspot.fr/

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par ichigobankai le Mar 6 Mar 2018 - 10:12

les couleurs d'écran ne sont pas vraiment pertinent...
Si tu peux essaie avec le bios de test ou un unibios qui pourra te sortir les plages d'adresses foireuses.
avatar
ichigobankai
Patient incurable

Masculin Nombre de messages : 1396
Age : 39
Localisation : 49
Date d'inscription : 04/04/2011

http://www.mastersystem-france.com

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par Hpman le Mar 6 Mar 2018 - 15:08

Ce que je vois d'après les deux photos, c'est que la machine affiche les bonnes tuiles au bon endroit, mais y'a une couille dans le potage au niveau de l'index de la couleur à utiliser.

Ça à l'air d'être un pixel sur deux, et les index de couleurs des pixels sont transmis par paire sur deux bus (GAD et GBD) depuis la cartouche vers le chip NEO-B0 (ou B1 selon revision). Un des deux bus semble capricieux ici.

T'as essayé de tripoter autour du B0/B1 pendant que la machine tourne? Ça peut paraître con mais parfois juste poser ses gros doigts partout déstabilise / fixe un signal un peu instable comme ça à l'air d'être le cas ici.

Ça se passe entre les pins 44 et 56, tu as le pinout détaillé sur le neogeodev wiki si tu veux les détails.

Hpman
Patient contaminé

Masculin Nombre de messages : 289
Age : 41
Localisation : Lille
Date d'inscription : 22/08/2014

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par eddyfoucault le Mar 6 Mar 2018 - 15:20

@Hpman a écrit:Ce que je vois d'après les deux photos, c'est que la machine affiche les bonnes tuiles au bon endroit, mais y'a une couille dans le potage au niveau de l'index de la couleur à utiliser.

Ça à l'air d'être un pixel sur deux, et les index de couleurs des pixels sont transmis par paire sur deux bus (GAD et GBD) depuis la cartouche vers le chip NEO-B0 (ou B1 selon revision). Un des deux bus semble capricieux ici.

T'as essayé de tripoter autour du B0/B1 pendant que la machine tourne? Ça peut paraître con mais parfois juste poser ses gros doigts partout déstabilise / fixe un signal un peu instable comme ça à l'air d'être le cas ici.

Ça se passe entre les pins 44 et 56, tu as le pinout détaillé sur le neogeodev wiki si tu veux les détails.

J'ai essayé de tout tripoter mais je vais retenter (avec toutes les précisions que tu apportes !!)

C'est lui ?


Je ne l'ai pas mais j'ai un LSPC-A0:

[url=https://servimg.com/view/18770878/116][/url]


Dernière édition par eddyfoucault le Mar 6 Mar 2018 - 15:29, édité 1 fois

eddyfoucault
Patient contaminé

Masculin Nombre de messages : 310
Age : 42
Localisation : lyon
Date d'inscription : 20/11/2014

http://eddystoys.blogspot.fr/

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par trunk70 le Mar 6 Mar 2018 - 15:28

@eddyfoucault a écrit:Salut,

je participe aussi à une discussion sur neo geo system, dont un membre sympa m'a orienté vers la coupure de pistes ... mais je n'ai rien vu. Alors la piste des composants toshiba m'intéresse.

@trunk70: s'agit il des composants sur la photo (mal prise) ? Cela se trouve dans le commerce ? avais tu les mêmes symptomes ?
@Hpman: bleu





Et pour les symptômes que j'avais cfr ma vidéo.

Et c'est vrai qu'avec l'unibios, c'est vachement plus simple de debugger le tout.
avatar
trunk70
Patient contaminé

Masculin Nombre de messages : 397
Age : 40
Localisation : Belgique (Mons)
Date d'inscription : 24/07/2012

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par Hpman le Mar 6 Mar 2018 - 19:51

@eddyfoucault a écrit:
@Hpman a écrit:Ce que je vois d'après les deux photos, c'est que la machine affiche les bonnes tuiles au bon endroit, mais y'a une couille dans le potage au niveau de l'index de la couleur à utiliser.

Ça à l'air d'être un pixel sur deux, et les index de couleurs des pixels sont transmis par paire sur deux bus (GAD et GBD) depuis la cartouche vers le chip NEO-B0 (ou B1 selon revision). Un des deux bus semble capricieux ici.

T'as essayé de tripoter autour du B0/B1 pendant que la machine tourne? Ça peut paraître con mais parfois juste poser ses gros doigts partout déstabilise / fixe un signal un peu instable comme ça à l'air d'être le cas ici.

Ça se passe entre les pins 44 et 56, tu as le pinout détaillé sur le neogeodev wiki si tu veux les détails.

J'ai essayé de tout tripoter mais je vais retenter (avec toutes les précisions que tu apportes !!)

C'est lui ?


Je ne l'ai pas mais j'ai un LSPC-A0:


Non c'est pas lui, il doit s'appeler PRO-B0 je crois sur cette carte mère, un des deux gros chip entre le port cartouche et les ports manette.

Edit: en fait ce se passe sur le PRO-C0 pour ce chipset, les deux ont été réunis par la suite.
Pins 113 à 120.

https://wiki.neogeodev.org/index.php?title=PRO-C0

Hpman
Patient contaminé

Masculin Nombre de messages : 289
Age : 41
Localisation : Lille
Date d'inscription : 22/08/2014

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par eddyfoucault le Ven 9 Mar 2018 - 15:07

Salut,

J'ai trouvé (enfin, c'était pas dur) le composant PRO-C0 ... j'ai décollé la mousse pour bien inspecter les pistes au voisinage de ce composant, et rien vu de suspect. J'ai bien tout tripoter avec mes gros doigts conducteurs et capacitifs, mais rien n'y a fait.

@ichigo: cette histoire d'unibios est certainement le bon moyen de faire un diag mais malheureusement hors de ma portée. Si mes recherches "simples" ne donennt rien, je vais essayer de trouver le docteur House des Neo Geo ? Si ce genre de personne existe, combien vous pensez qu'il faille mettre au maximum dans cette réparation (sachant qu'il y aura un risque que le mec échoue et que je devrai le payer quand même)

eddyfoucault
Patient contaminé

Masculin Nombre de messages : 310
Age : 42
Localisation : lyon
Date d'inscription : 20/11/2014

http://eddystoys.blogspot.fr/

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par Hpman le Ven 9 Mar 2018 - 19:18

Ôte nous d'un doute, tu as test un autre jeu? Qu'on s'emmerde pas pour un fatal 2 moisi

Hpman
Patient contaminé

Masculin Nombre de messages : 289
Age : 41
Localisation : Lille
Date d'inscription : 22/08/2014

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par eddyfoucault le Ven 9 Mar 2018 - 19:20

Oui je te rassure :) ... et le ff2 fonctionne sur mon autre console
Ceci dit ta remarque aura eu le don de me faire rire en cette période de deuil !!

eddyfoucault
Patient contaminé

Masculin Nombre de messages : 310
Age : 42
Localisation : lyon
Date d'inscription : 20/11/2014

http://eddystoys.blogspot.fr/

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par Hpman le Mer 28 Mar 2018 - 14:23

Tjrs en rade cette neo? Je veux bien jeter un œil dessus, tant que tu casques pour le port Mr. Green
Je pense pas que ce soit la VRAM, mais au moins avec la machine sous le coude je peux écrire et faire tourner des programmes de tests.

Hpman
Patient contaminé

Masculin Nombre de messages : 289
Age : 41
Localisation : Lille
Date d'inscription : 22/08/2014

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par eddyfoucault le Mer 28 Mar 2018 - 15:42

@Hpman a écrit:Tjrs en rade cette neo? Je veux bien jeter un œil dessus, tant que tu casques pour le port Mr. Green
Je pense pas que ce soit la VRAM, mais au moins avec la machine sous le coude je peux écrire et faire tourner des programmes de tests.

Salut,

oui, toujours en rade ... en fait sur un autre forum, on m'avait conseillé de lâcher l'affaire avec une NG 5V, visiblement réputée pour être moins fiable que les modèles 9V. Attention, quand je dis qu'on m'a invité à lâcher l'affaire, c'est que dès le départ j'ai avoué ne pas avoir le temps et/ou les compétences pour trifouiller des trucs comme "unibios" ...

donc, déjà, c'est super sympa à toi de me proposer ton aide, j'apprécie réellement. En fdp il doit y en avoir pour uen vingtaine d'euros A/R je pense. Pour 20 euros, penses tu qu'il faille tenter le coup ou bien investir dans un petit jeu sympa sur une autre machine ? En d'autres termes, tu le sens comment ? T'as déjà réanimé des NG dans cet état ?

à très bientôt

eddyfoucault
Patient contaminé

Masculin Nombre de messages : 310
Age : 42
Localisation : lyon
Date d'inscription : 20/11/2014

http://eddystoys.blogspot.fr/

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par Hpman le Mer 28 Mar 2018 - 15:52

Ce problème en particulier je l'ai jamais rencontré, mais j'ai déjà retapé quelques machines ouais.
Forcément je peux rien garantir à part de pouvoir faire tout les tests qui me passent par la tête, donc c'est à toit de voir si tu tentes le coup. Si tu dors déjà dehors je te conseille de garder ces 20€ Mr. Green

Hpman
Patient contaminé

Masculin Nombre de messages : 289
Age : 41
Localisation : Lille
Date d'inscription : 22/08/2014

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par eddyfoucault le Mer 28 Mar 2018 - 16:10

@Hpman a écrit:Ce problème en particulier je l'ai jamais rencontré, mais j'ai déjà retapé quelques machines ouais.
Forcément je peux rien garantir à part de pouvoir faire tout les tests qui me passent par la tête, donc c'est à toit de voir si tu tentes le coup. Si tu dors déjà dehors je te conseille de garder ces 20€ Mr. Green

je te rassure, je n'en suis pas à ce point là :) (je revendrai plein de choses avant ce stade !!)
écoute, j'essaie de passer à la poste dans les jours qui suivent et je te tiens au courant en MP (ce serait quand même trop beau de retrouver ma console !!)

(si t'as un soucis de RGB sur une pc engine n'hésite pas Wink )

eddyfoucault
Patient contaminé

Masculin Nombre de messages : 310
Age : 42
Localisation : lyon
Date d'inscription : 20/11/2014

http://eddystoys.blogspot.fr/

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par eddyfoucault le Mer 16 Mai 2018 - 11:17

Bonjour à tous,

Bon voilà, je clos ici ce sujet car ... j'ai retrouvé la Neo Geo de mon enfance !!!
Je tiens à vous remercier tous, pour vos conseils.
Je tiens évidemment à remercier plus particulièrement l'un d'entre vous, qui a pris de son temps pour résoudre le soucis. Un ami me disait que l'on a souvent tendance à oublier qu'Internet est un formidable outil communautaire ... mais parfois on tombe sur des gens biens qui nous le rappelle.

Je ne vais pas donner des détails techniques, car je ne les maîtrise pas. Juste une photo pour vous montrer quel était l'élément défaillant. Pour plus de précisions, eh ben je vous laisse contacter HPMAN :)



Aussi, pour terminer, je voulais faire une petite remarque concernant la qualité d'image de cette console. Je m'étais habitué à l'image de sa remplaçante, une version 9V, pour laquelle j'avais noté un certain "flou". Sur la version 5V, ce flou n'existe pas, l'image est bien plus nette, et les couleurs moins flashy. Je n'en connais pas la raison, c'est juste la remarque d'un maniaque.

A bientôt pour de nouvelles aventures :)

eddyfoucault
Patient contaminé

Masculin Nombre de messages : 310
Age : 42
Localisation : lyon
Date d'inscription : 20/11/2014

http://eddystoys.blogspot.fr/

Revenir en haut Aller en bas

Re: Probleme neo geo

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum