soucis Amiga600

Voir le sujet précédent Voir le sujet suivant Aller en bas

soucis Amiga600

Message par kaot le Mar 28 Juil 2015 - 16:29

hello
je cherche comment plugger une souris USB sur un port DB9, comme on en trouve sur le ST ou l'AMIGA. (en effet, les boutons de ma souris ATARI ont subi les affres de l'usure et du temps, ils sont quasi morts, c'est inutilisable en l'état, je parle même pas de la boule qui est devenue quasi cubique, et des axes qui sont grippés).


solution envisagée : utiliser une souris USB avec un adaptateur.

j'ai trouvé ce genre d'accessoire


mais il faudrait encore rajouter un adaptateur usb male/femelle, (ca commence a faire beaucoup) et je ne suis pas du tout sûr que ca fonctionne au final.

est-ce qu'un gamopat fou à déja été confronté a ce probleme et utilise ce genre d'accessoire? ou voit une solution plus appropriée pour utiliser une souris moderne sur une machine oldschool ? merci d'avance


Dernière édition par kaot le Ven 31 Juil 2015 - 14:37, édité 1 fois

kaot
Patient incurable

Masculin Nombre de messages : 1609
Age : 38
Localisation : la bas
Date d'inscription : 12/02/2015

Revenir en haut Aller en bas

Re: soucis Amiga600

Message par pcengineman le Mar 28 Juil 2015 - 17:02

ce topic en parle justement


http://www.yaronet.com/board/topic/119543

pcengineman
Patient contaminé

Masculin Nombre de messages : 152
Age : 39
Localisation : belgique
Date d'inscription : 25/05/2014

Revenir en haut Aller en bas

Re: soucis Amiga600

Message par kaot le Ven 31 Juil 2015 - 15:03

ca en fait des adaptateurs Very Happy a ce que j'ai lu tu peux mettre une souris PS2 avec un simple adaptateur, mais en USB il faut un convertisseur sinon ca ne marchera pas. bon a savoir.

j'ai une autre galère : le clavier à un comportement qui me laisse dubitatif.
j'ai démonté le clav, nettoyé les contacts coté clavier et la "feuille" jusqu'au bout qui rentre dans le connecteur sur la CM. j'ai regagné ma touche CAPS LOCK avec la led qui s'allume mais :

-si je pousse un peu la nappe vers le centre de l'ordi, A,A et CTRL marchent. mais pas la touche ESC.
-si je touche a rien, A,A et CTRL ne marchent plus, mais la touche ESC est opérationnelle.
(j'ai testé dans le soundtest de turrican 2 MDR)
-dans les 2 cas, la touche 5 ne donne pas signe de vie, et parfois l'intensité de la Led CapsLock fait du yoyo.



j'hésite entre la nappe clavier qui a pris un pli de trop, le connecteur qui dit merde au niveau de la carte mère saispas , le clavier mort pour de bon ou cette fameuse histoire de condensateurs (la led pas stable).

est-ce qu'on peut retirer le clip en plastique (sur le connecteur clavier de la carte mère) sans le casser?



et aussi, s'il y a quelqu'un qui a un 600 version carte-mère pas blindée (comme sur la photo), ca m'interesserait de voir comment sont fixés les lecteurs de disquettes et les claviers sur vos bécanes.

kaot
Patient incurable

Masculin Nombre de messages : 1609
Age : 38
Localisation : la bas
Date d'inscription : 12/02/2015

Revenir en haut Aller en bas

Re: soucis Amiga600

Message par pcengineman le Ven 31 Juil 2015 - 18:19

c 'est la nappe! au bout c des pistes  carbonée elle sont surement usée coupe 1mm sur le bout de la nappe proprement avec un cutter et réessaie

pcengineman
Patient contaminé

Masculin Nombre de messages : 152
Age : 39
Localisation : belgique
Date d'inscription : 25/05/2014

Revenir en haut Aller en bas

Re: soucis Amiga600

Message par kaot le Lun 3 Aoû 2015 - 14:26

@pcengineman a écrit:c 'est la nappe! au bout c des pistes  carbonée elle sont surement usée coupe 1mm sur le bout de la nappe proprement avec un cutter et réessaie
Shocked tu as déja eu ce cas- la?

kaot
Patient incurable

Masculin Nombre de messages : 1609
Age : 38
Localisation : la bas
Date d'inscription : 12/02/2015

Revenir en haut Aller en bas

Re: soucis Amiga600

Message par pcengineman le Lun 3 Aoû 2015 - 18:47

oui sur un 1200 c la meme nappe en plastique,ton connecteur est en bon etat?

pcengineman
Patient contaminé

Masculin Nombre de messages : 152
Age : 39
Localisation : belgique
Date d'inscription : 25/05/2014

Revenir en haut Aller en bas

Re: soucis Amiga600

Message par Doctoritchy le Lun 3 Aoû 2015 - 21:26

pour la souris il faut un convertisseur spécial  cela est fait avec un petit pic 16f84 et le code qui va bien , car une souris atari ou amiga n'est pas une souris serie  elle sort un signal en quadrature pour l'axe Y et un autre pour l'axe Y et les bouton son directement connecter au port souris :)  donc il faut convertir le signal serie ou usb en signal as quadrature cela n'est pas réalisable sans microcontroleur comme le pic 16f84 :)

pour le clavier avant de couper passe un coup de gomme tendre sur les piste coter connecteur  et change les condo alim , il ont de l'age il n'est pas inutile de les changer si il n'ont pas encore fuit il risque de poser soucis dans le futur Wink

vois aussi si tu n'as pas une soudure coter carte mere ou clavier qui n'as pas seché et qui as lacher Wink

Doctoritchy
Patient contaminé

Masculin Nombre de messages : 247
Age : 37
Localisation : Belgique
Date d'inscription : 26/04/2015

Revenir en haut Aller en bas

Re: soucis Amiga600

Message par kaot le Mer 5 Aoû 2015 - 15:59

pour le clavier avant de couper passe un coup de gomme tendre sur les piste coter connecteur  et change les condo alim , il ont de l'age il n'est pas inutile de les changer si il n'ont pas encore fuit il risque de poser soucis dans le futur

ok je note

vois aussi si tu n'as pas une soudure coter carte mere ou clavier qui n'as pas seché et qui as lacher

enfer !!! j'espere que non. je peux pas voir ca avant de virer le blindage et ce fameux clip en plastique que je suis pas sur de pouvoir oter sans le casser.

pour le blindage je vois pas de vis oO tout est tenu avec ces fameuses pattes métalliques... il faut les tordre pour libérer le blindage ? est-ce que je peux faire tourner la machine sans ce fameux blindage (qu'il faudra de toute facon oter pour virer la rouille et changer les condos) ?

kaot
Patient incurable

Masculin Nombre de messages : 1609
Age : 38
Localisation : la bas
Date d'inscription : 12/02/2015

Revenir en haut Aller en bas

Re: soucis Amiga600

Message par kaot le Mer 5 Aoû 2015 - 16:16

autre question qui me trotte dans la tête

si je prends un clavier d'occase (un qwerty) la langue du clavier est définie par le soft qui tourne / le workbench ou par le clavier? (je me souviens que pas mal de jeux etaient en qwerty malgré le clav azerty, je dirai donc que ca se fait en soft mais je suis pas sur du tout) est-ce que ca risque de poser souci par la suite?

kaot
Patient incurable

Masculin Nombre de messages : 1609
Age : 38
Localisation : la bas
Date d'inscription : 12/02/2015

Revenir en haut Aller en bas

Re: soucis Amiga600

Message par Doctoritchy le Mer 5 Aoû 2015 - 16:51

sur le a500 il y as 4 ou 5 vis tork as retiré et dévissé les écrous des connecteur DB as l’arrière  plus des petite patte as déplier , oui tu peu faire tourné la machine sans le blindage c'est un blindage emf pour evité les interférence  si tu n'as pas de source qui peu capter les haute fréquence  et de générateur haute fréquence qui tourne as coter ( radio CB , micro onde , gsm , téléphone sans fil , wifi puissant , ect ) pas vraiment de soucis , juste faire gaffe de pas faire un court circuit sur les pistes et eviter de toucher les composant avec les doigts :) 

quand tu change les condo note bien le coter négatif et positif il est facile de se tromper et après PAF le condo + dégât possible sur la carte mere !  , quand tu dessoudé fait gaffe de ne pas abîmé les pastille du pcb , l’idéal c'est "d'arracher" le condo normalement en tirant délicatement les pin se détache dans le condo  si cela ne vient pas tout seul ne pas insister :)  et dessoudé avec un fer as air chaud c'est l’idéal :)  , pour la rouille frotté la carcasse avec une éponge gex en limaille de fer et de préférence loin de toute carte et composant électronique  après il faudra absolument soit re chromé le métal (opération pas trop complexe mais qui demande un peu de matos  et du chrome pur en barre ! )  soit plus simplement mettre une fine couche de vernis "pcb" ou tout vernis isolant , sinon cela rouilleras aussi vite , pour dérouillé et viré le chromage  facilement il y as aussi l'acide chlorhydrique trouvable en bidon de 5 litre au brico , et tremper la pièce entière dans l'acide et la laisser entre 20 et 60minute , tout en surveillant toute les 5-10 minute :)  et bien rincer as l'eau déminéralisée  et attention les doigt :) 


si tu change le clavier  il resteras en azerty si il est configuré en azerty dans le workbench , mais  on sais dé-clipsé les touche du clavier facilement  donc tu peu faire un échange de touche tout simplement Wink

Doctoritchy
Patient contaminé

Masculin Nombre de messages : 247
Age : 37
Localisation : Belgique
Date d'inscription : 26/04/2015

Revenir en haut Aller en bas

Re: soucis Amiga600

Message par kaot le Mer 5 Aoû 2015 - 16:54

impec ! merci pour tes réponses. doctoritchy

kaot
Patient incurable

Masculin Nombre de messages : 1609
Age : 38
Localisation : la bas
Date d'inscription : 12/02/2015

Revenir en haut Aller en bas

Re: soucis Amiga600

Message par Contenu sponsorisé Aujourd'hui à 17:50


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum