[RESOLU]Switch SNES foireux ?

Voir le sujet précédent Voir le sujet suivant Aller en bas

[RESOLU]Switch SNES foireux ?

Message par Gibbon le Ven 1 Mai 2015 - 15:54

Salut tout le monde,

Ça faisait longtemps dis donc :)

Je vous écris car je viens de switcher ma SNES pour profiter du 60Hz et j'ai des bugs graphiques sur absolument tous les jeux quand je les passe en 60Hz. Exemple, en 50Hz :



En 60 Hz pour le même jeu, le bas de l'écran "saute" passant de l'image normale à une image décalée (mais seulement le bas) :



Petites précisions :

  • j'ai vérifié la continuité de toutes mes soudures au multimètre, elles sont toutes bonnes ;
  • j'ai isolé les pattes levées des PPU1 et 2 et du lockout chip ;
  • ça le fait sur tous les jeux que j'ai testés mais pas toujours de la même manière (Mortal Kombat fait à peu près la même chose dans les menus, mais presque pas dans le jeu ; sur ISS Deluxe tout l'écran déconne dans les menus)
  • je n'ai pas de péritel sur ma TV, donc je passe tout par un XRGB-Mini.


Je me retrouve donc un peu coincé : je pense que si j'avais complètement foiré une partie du mod j'aurai rien du tout mais là en 50Hz tout roule, c'est vraiment le 60Hz qui est foireux (et malheureusement, j'ai pas de jeux Jap ou US pour tester). C'est super rageant parce que ça "presque" marche Sad

Est-ce que qqn aurait déjà été confronté à ce cas et pourrait éventuellement me donner la solution ? Est-ce que ça pourrait venir du XRGB-Mini (peu probable mais bon) ?


Dernière édition par Gibbon le Dim 3 Mai 2015 - 17:49, édité 2 fois

Gibbon
Visiteur de l'hôpital

Masculin Nombre de messages : 17
Age : 32
Localisation : Au fond à gauche
Date d'inscription : 14/10/2012

Revenir en haut Aller en bas

Re: [RESOLU]Switch SNES foireux ?

Message par onels4 le Ven 1 Mai 2015 - 15:57

Je déplace vers la section réparation.

onels4
Docteur Modérateur ****
Docteur Modérateur ****

Masculin Nombre de messages : 69701
Age : 35
Localisation :
Date d'inscription : 22/05/2011

Revenir en haut Aller en bas

Re: [RESOLU]Switch SNES foireux ?

Message par Gibbon le Ven 1 Mai 2015 - 21:31

J'ai essayé avec un autre câble péritel et cela semble un peu mieux : Pop'n Twinbee déconne toujours dans les menus, mais presque plus dans le jeu.

Pareil pour ISS : les menus sont complètement glitchés mais en jeu ça passe beaucoup mieux.

Du coup, ça pourrait venir de quoi à votre avis ? Souci d'isolation qqs parts ?

EDIT: et au passage, merci pour le déplacement, je ne m'étais pas rendu compte qu'il y avait un forum spécial pour ça :)

Gibbon
Visiteur de l'hôpital

Masculin Nombre de messages : 17
Age : 32
Localisation : Au fond à gauche
Date d'inscription : 14/10/2012

Revenir en haut Aller en bas

Re: [RESOLU]Switch SNES foireux ?

Message par barbarian_bros le Ven 1 Mai 2015 - 22:36

@Gibbon a écrit:
je n'ai pas de péritel sur ma TV, donc je passe tout par un XRGB-Mini.
Est-ce que qqn aurait déjà été confronté à ce cas et pourrait éventuellement me donner la solution ? Est-ce que ça pourrait venir du XRGB-Mini (peu probable mais bon) ?

T'as pas un pote/voisin/parent qui a une TV avec péritel pour tester sans le XRGB-Mini ? Ça me semble le meilleur moyen de savoir si le pb vient de ta console ou de ton branchement vidéo.

barbarian_bros
Docteur *
Docteur *

Masculin Nombre de messages : 4172
Age : 39
Localisation : 33
Date d'inscription : 29/11/2009

Revenir en haut Aller en bas

Re: [RESOLU]Switch SNES foireux ?

Message par Gibbon le Sam 2 Mai 2015 - 0:28

Ta réponse m'a mis sur une piste : j'ai pas de péritel, mais j'ai une entrée composite (beurk…) sur le devant de la télé.

Je viens donc de brancher ma SNES en composite avec un vieux câble N64 qui traînait dans un coin : tout marche correctement en 50 comme en 60Hz.

Du coup, j'ai essayé de brancher la SNES en composite sur le XRGB-Mini pour voir : autant en 50Hz, il affiche correctement l'image, autant en 60Hz, il n'affiche que du noir et blanc.

Je pense que ça doit être un problème de synchro ou de norme PAL/NTSC (pourtant me semblait bien qu'il pouvait faire du PAL60…).

Le problème est pas résolu mais en tout cas, ça ne vient pas du switch !

Gibbon
Visiteur de l'hôpital

Masculin Nombre de messages : 17
Age : 32
Localisation : Au fond à gauche
Date d'inscription : 14/10/2012

Revenir en haut Aller en bas

Re: [RESOLU]Switch SNES foireux ?

Message par Gibbon le Dim 3 Mai 2015 - 17:48

Pour ceux qui tomberaient par hasard sur le topic (via moteurs de recherche par exemple), je viens de complètement résoudre le problème : en fait, les SNES moddées selon cette méthode (quelques soudures toutes connes) sortent un signal en 59.54Hz un peu loin du standard NTSC (59.94) pour être compréhensible directement par le XRGB-Mini.

Pour résoudre le problème, il faut :

  • aller dans SYNC_SET > SYNC_MODE et le mettre sur OFF (ça permet de s'assurer que ce signal un peu foireux n'est pas transmis à la télé, elle pourrait ne pas le supporter ; en l'occurence la mienne a l'air de gérer ça correctement mais au moins, vous serez pas surpris) ;
  • dans SYNC_SET > SYNC_LEVEL, pousser le curseur jusqu'à 22 (en dessous, j'avais toujours des artéfacts dans certains menus/jeux)


Voilà, en toute logique, ça devrait vous permettre de profiter de votre XRGB-Mini et votre SNES switchée sans problème !

Gibbon
Visiteur de l'hôpital

Masculin Nombre de messages : 17
Age : 32
Localisation : Au fond à gauche
Date d'inscription : 14/10/2012

Revenir en haut Aller en bas

Re: [RESOLU]Switch SNES foireux ?

Message par Contenu sponsorisé Aujourd'hui à 11:28


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum